This project is read-only.

Welcome to Touchless!

Oct 7, 2008 at 6:58 PM
Have feedback, a question, an idea please feel free to discuss it here :)

Cheers
Nicole
Oct 8, 2008 at 5:33 PM
Hello,
Just heard about this project this morning when I got to work, and have been playing with it a bit.  I'm pretty excited about the project, and am interested in doing a little programming for it.  But when I started, I ran into an issue...
I have the full version of Visual Studio 2005.  I opened a new project, a c# project, and attempted to add the two dlls to the references.  The TouchlessLib added, but the WebcamLib would not add, saying that:
"A reference to ...WebcamLib.dll' could not be added.  Please make sure that the file is accessible, and that it is a valid assembly or COM component."
The WebcamLib file is located in the same directory as the TouchlessLib, so I would think the first part is ruled out; I have not used references before in Visual Studio, as my background has been mostly straight C and Java, but it seemed to be fairly straightforward... so is there something obvious that I'm missing?

Oct 8, 2008 at 5:54 PM
Hi there,

I'm glad your interested in trying out Touchless.  WebcamLib doesn't need to be added as a reference to your project only TouchlessLib.  WebcamLib is unmanaged code written in C++ and it is referenced directly in the code of TouchlessLib.  All you will need to do is ensure that WebcamLib is in your project output directory when you run your program.  If you watch the Walkthrough video in the Documentation directory it will show you how to do this.

Oct 9, 2008 at 12:28 AM
Hello, 
I can't wait to try this out when I get home.  My kids will get a kick out of it. 
I was wondering if I could use my miniDV Camcorder instead of buying a WEBcam just for this tool.  If you don't know then I will let you know when I try it out tonight.  I was just wondering if anyone has tested the samples with a miniDV camcorder yet.
Thanks,
CROW
Oct 9, 2008 at 1:25 AM
Hi Crowsoft,
Thanks for the post. If your device works with Microsoft DirectShow (a multimedia framework for video input, etc.) it will work with Touchless. I don't expect you to buy a webcam to use Touchless, but I wouldn't stop you ;-). I can definitely see potential to build educational and entertaining Touchless applications/games targeted to youth, kids even really liked my Touchless Demo little demos at our last Microsoft Office Labs Productivity Science Fair!
Oct 10, 2008 at 1:58 PM
Hello,
  This is really cool, and why didn't I take my webcam to work today :). Well will have to wait few hours to go home :(.

  Lukasz
Oct 16, 2008 at 4:39 AM
Edited Oct 16, 2008 at 4:44 AM
Hi, $0Thank you for explaining how to run the touchless program but I still encounter this error(The command "copy C:\Documents and Settings\admin\Desktop\Touchless\Samples\TouchlessDemo\..\..\bin\Release\WebCamLib.dll C:\Documents and Settings\admin\Desktop\Touchless\Samples\TouchlessDemo\bin\Release\WebCamLib.dll" exited with code 1.)$0$0I'm  pretty new programmer and I don't know much about C# so I didn't get what the error means$0$0
Oct 16, 2008 at 5:04 AM
Hi yasirutp,

That means that the post-build event of copying WebCamLib.dll failed. You should ensure that your directory structure is setup as it is in our code repository, make sure the file is in the source location, and can be copied to the destination. If you want, you can also modify or remove the post-build event to suit your needs. Try right clicking the project in Solution Explorer, click properties and look around for the post-build event's copy command.
Good luck and post a new topic if you have more questions!

- Mike
Oct 16, 2008 at 11:17 AM
Thanks so much Mike for the fast reply$0Actually as I said earlier I'm very new in C# I didn't get how can I edit my post-build event $0$0my post-build event command is empty I don't now what to add to it.$0$0I didn't create a new project I just download the project file and run it but I still get that error$0$0$0$0$0-Yasir $0
Oct 17, 2008 at 12:19 AM
My mistake, the copy command is in the PRE-build event command line. The easiest option for you is probably to remove this command altogether. But be sure to copy WebCamLib.dll into your output directories for Touchless Demo. The way to remove the pre-build copy command is to right click on the project "TouchlessDemo", listed under "Solution 'TouchlessDemo'" in the Solution Explorer. Navigate to the Build Events tab, and it's right there. Remove the command "copy $(SolutionDir)..\..\bin\Release\WebCamLib.dll $(TargetDir)WebCamLib.dll" from the "pre-build event command line" text field. Save everything, and try rebuilding. I hope this works for you.
Oct 17, 2008 at 7:32 AM
Oh thanks so much $0$0$0That's alright now I managed to get it running $0$0This gonna be very helpful for game programmers$0$0$0$0$0That's cool Mike Thanks$0$0
Oct 24, 2008 at 10:20 AM
Edited Oct 24, 2008 at 10:25 AM
Hi Mike$0I'm trying to use your touchless library to capture from two cameras but I'm facing some problems doing it. I'm trying to use two (TouchlessMgr) objects To access the two cameras$0 TouchlessMgr _touchCam1 = new TouchlessMgr();$0        TouchlessMgr _touchCam2 = new TouchlessMgr();$0 but it seems it is not the right way. do you have any idea that how it could be done. I'm doing some stereo application that's way I need to deal with multiple cameras$0Regards$0-Yasir
Oct 25, 2008 at 11:35 PM
Hi Yasirutp,

Sounds like you're working on an interesting project. Touchless hasn't been tested for this sort of use, but I'd still like to help you and make it work.
I don't see anything offhand that would prevent creating multiple instances of TouchlessMgr; please give more detail about the problem you're seeing.
Perhaps create a new discussion thread that will address this problem specifically. I'd also be happy to look at your code and do a little investigative work.

- Mike
Oct 29, 2008 at 1:52 AM
H Mike,

I have created a new discussion lists by the title "multi-camera touchless"

Regards,

Yasir,
Sep 10, 2009 at 8:09 AM

I am facing the same problem as discussed by yasirutp and michwass. I tried the solution suggested by michwass but it still showing the same error message....

Can u put some light on this why doing all the things right i am still facing the same problem?

Any reply will be appriciated.

Regards

Akki

Sep 10, 2009 at 11:22 PM

Akki619, Did you remove any pre- or post-build events from the projects? Please double check that... The error just means that it can't a binary built by the project or the target location of the command in the event.

Sep 11, 2009 at 4:54 AM

Thanks Michwass....

After posting my query, I tried to solve it in many ways and found out that Visual Studio version may be a problem...

So yesterday, I updated my .Net version 2.0 and Visual Studio 2005 with .Net 3.5 and Visual Studio 2008 and the application is now working properly.

Thanks once again for your quick response....

Regards,

Akki

Feb 16, 2010 at 10:54 AM

I have problem when i'm trying to add reference to WebCamLib.dll in VC++ project. I'm have error "Could not add reference to file "WevCamLib.dll' because it is neither a .NET assembly or registered ActiveX control". I found another copy of .dll with example form other website, and I can add reference, but later I have problem to run compiled program.

Feb 16, 2010 at 9:40 PM

You shouldn't have to add a reference directly to WebCamLib if you are just using TouchlessLib.

Otherwise, try building WebCamLib for your target platform and referencing that, or include the WebCamLib project in your solution.

Mar 11, 2010 at 3:47 PM

Im sorry can u please sent me the link of the video as im unable to find it

-dan

May 29, 2010 at 6:51 PM

hi all

I am having problem with webcamlib .....  when I compile i get errors and warnings

Warning    3    The referenced component 'WebCamLib' could not be found.     

Error    1    The type or namespace name 'WebCamLib' could not be found (are you missing a using directive or an assembly reference?)    C:\Documents and Settings\Owner\My Documents\CapsTone_Project\touchless-30139\TouchlessLib\TouchlessMgr.cs  

Error    2    The type or namespace name 'CameraMethods' could not be found (are you missing a using directive or an assembly reference?)    C:\Documents and Settings\Owner\My Documents\CapsTone_Project\touchless-30139\TouchlessLib\Camera.cs

Error    4    The type or namespace name 'WebCamLib' could not be found (are you missing a using directive or an assembly reference?)    C:\Documents and Settings\Owner\My Documents\CapsTone_Project\touchless-30139\TouchlessLib\Camera.cs  

 

I tried all possible you posted but still i get these errors and warnings and also when I tried open it by microsoft visual C# 2008 express edition i get this message (webcamlib\webcamlib.vcproj could not be opened because its project type (.vcproj) is not supported by this version of this application)    ...  i hope you replay me fast because I need for my graduation project

please replay me fast

thanks in advance

regards,

Mariam

 

 

May 29, 2010 at 11:51 PM
Edited May 29, 2010 at 11:55 PM

Mariam

You are getting these errors because you are trying to open it from touchless.sln. Rather you need to go to .\samples\touchlessDemo\ and find the file named TouchlessDemo.csproj, double click it and run. This will definitly work. Have fun.

Jun 4, 2010 at 7:17 PM

hi everyone

i tried tcouless and it was awesome project .... but have some suggestion and i need help and advise of how to enhance this project .... i want to integrate multipoint sdk with touchless at same time i want to use silverlight

second can we use two cameras with two mouse demo .... ?

 

thanks in advance ..

regards,

Mariam

Dec 4, 2010 at 1:39 PM
Edited Dec 4, 2010 at 1:40 PM

hi 

when i tried to add the two dll files to my project i could add the touchlessLib.dll but i could not add the webCamLib.dll  when i tried to add that 

visual studio gave me an error saying A referance to 'C:\zstuff\sw\touchless\WebCamLib.dll' could not be added.Please make sure that the file is accessible, and that it is a valid assembly or COM component

i'm using vs2008 and my os is 64 bit.Plz tl me how to fix this